---
title: "Gem pg na Ubuntu 22"
url: https://michalasobczak.pl/pl/posts/pg-gem-on-ubuntu-22.html
author: "Michał Sobczak"
description: "Myślałem, że instalacja gema pg na czystym Ubuntu 22 będzie łatwa, ale nie. Dostałem dziwny komunikat: Spróbowałem więc wymusić instalację: Następnie: W tym wydaniu Ubuntu 22, instalując interpreter Ruby z pakietów, dostajesz wersję 3.0.2p107."
published: 2022-12-02T09:02:20.000Z
updated: 2022-12-02T09:02:20.000Z
language: pl
categories: ["Technology"]
tags: ["Ruby / Rails", "Ubuntu"]
license: CC BY-NC-ND 4.0 (https://creativecommons.org/licenses/by-nc-nd/4.0/)
---
# Gem pg na Ubuntu 22

Myślałem, że instalacja gema pg na czystym Ubuntu 22 będzie łatwa, ale nie. Dostałem dziwny komunikat:

```bash
The following packages have unmet dependencies:
 libpq-dev : Depends: libpq5 (= 14.5-0ubuntu0.22.04.1) but 15.1-1.pgdg22.04+1 is to be installed
E: Unable to correct problems, you have held broken packages
```

Spróbowałem więc wymusić instalację:

```bash
sudo apt-get install libpq5=14.5-0ubuntu0.22.04.
```

Następnie:

```bash
sudo apt install libpq-dev
sudo gem install pg
```

W tym wydaniu Ubuntu 22, instalując interpreter Ruby z pakietów, dostajesz wersję 3.0.2p107. Problem mógł wynikać z wcześniej zainstalowanego pgadmin4, który mógł coś zepsuć.
